linux/tools/build/feature/test-llvm.cpp
<<
>>
Prefs
   1// SPDX-License-Identifier: GPL-2.0
   2#include "llvm/Support/ManagedStatic.h"
   3#include "llvm/Support/raw_ostream.h"
   4#define NUM_VERSION (((LLVM_VERSION_MAJOR) << 16) + (LLVM_VERSION_MINOR << 8) + LLVM_VERSION_PATCH)
   5
   6#if NUM_VERSION < 0x030900
   7# error "LLVM version too low"
   8#endif
   9int main()
  10{
  11        llvm::errs() << "Hello World!\n";
  12        llvm::llvm_shutdown();
  13        return 0;
  14}
  15