linux/include/linux/compiler-gcc3.h
<<
>>
Prefs
   1#ifndef __LINUX_COMPILER_H
   2#error "Please don't include <linux/compiler-gcc3.h> directly, include <linux/compiler.h> instead."
   3#endif
   4
   5#if __GNUC_MINOR__ < 2
   6# error Sorry, your compiler is too old - please upgrade it.
   7#endif
   8
   9#if __GNUC_MINOR__ >= 3
  10# define __used                 __attribute__((__used__))
  11#else
  12# define __used                 __attribute__((__unused__))
  13#endif
  14
  15#if __GNUC_MINOR__ >= 4
  16#define __must_check            __attribute__((warn_unused_result))
  17#endif
  18
  19#ifdef CONFIG_GCOV_KERNEL
  20# if __GNUC_MINOR__ < 4
  21#   error "GCOV profiling support for gcc versions below 3.4 not included"
  22# endif /* __GNUC_MINOR__ */
  23#endif /* CONFIG_GCOV_KERNEL */
  24
lxr.linux.no kindly hosted by Redpill Linpro AS, provider of Linux consulting and operations services since 1995.